Transaction or DCG Is Marked as Huge
Symptom
In the Transaction or Data Call Graph scope, an item in the list is marked with the message: “Huge Transaction, content is filtered” or similar. When you select it, no graph is displayed.
Cause
During the import process, CAST Imaging found that this transaction or data call graph contains more than 10,000 objects. The importer stopped processing it to prevent performance problems. The detail of this transaction is not available in the graph.
Resolution
Option 1: Download as CSV
At the transaction level, use the Download button in the Simplified Call Graph settings to export the transaction data as a CSV file. You can then analyze it offline.
Option 2: Increase the threshold
If you need to display large transactions in the viewer, increase the threshold that triggers the “huge” warning.
See Monitor and tune performance — Configure huge transaction threshold.
Increasing this threshold may cause the import to take much longer and may cause performance issues in the viewer for the affected transactions.
Option 3: Re-run the import
After changing the threshold, re-import the application to process previously skipped transactions.
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